Tools/Versions

From UIT
Jump to: navigation, search

Contents

This is a list of the tools and the corresponding version we use in our projects. You can find the files in two places:

Check also I:\RaD\SI-ET\Projets\A201-203-309\ to find the versions installed on the lab computers.

For space improvements, only versions related to a project in the list below are kept on Oliver's Software Server.


@Students

  • For laboratory work use the Labo version.
  • For semester or diploma work, follow the recommendations of your professor/assistant.

Mentor HDL-Designer

2017.1a

  • Labo18

version 2017.1 vs. 2015.1

+ Support for Windows 10

+ many features and fixes for Subversion, Design Checker, XilinxV ivado, VHDL 2008 and SV-VHDL Assistant

2015.2

C:\eda\MentorGraphics\HDS\

  • Labo16
  • Dormouse

version 2015.1 vs. 2009.2

+- vector range has to be entered completely manually, no more dropdown for <downto>,<to>

+ compatible with ModeSim v.10 and newer

- numeric_std.vhdl empty

+ SystemVerilog-VHDL Assistant

+ Vivado integration

2012.1

2011.1

2009.2

C:\eda\HDS\

  • Labo / EDA libs
  • PoUSSyERE
  • ADELE
  • BasMI
  • VerifThin
  • EzCat
  • PureDigital
  • OLGM

2007

  • HRTM

Mentor Modelsim

Of the different revisions (a,b,c,...) only the latest will be kept.

10.7

  • Labo18

version 10.7 vs. 10.4

+ supports Windows 10

+ type conversion from a floating point type to an integer type will now produce an Error message if the floating point value is outside the range of a signed 32-bit integer

+ nested .do files

+ also runs if installed in paths with spaces

- -novopt deprecated

10.4

C:\eda\MentorGraphics\ModelSim\win64\

  • Labo / EDA libs
  • Dormouse

version 10.4 vs. 6.6

+ constants are visible in Objects List and can be added to Waveform

+ show vector and array indexes

+ capitalization same as in VHDL

+ base can be shown

+ Global Signal Radix

+ marks In-/Outputs

+ shows which signals are not logged in Objects View

- does not mark FSMs

- BUG: setting base does not work if multiple signals selected

- not compatible with HDL-Designer 2009.2

10.3

10.2

6.6

C:\eda\Modelsim\win32\

Mentor Questa

Of the different revisions (a,b,c,...) only the latest will be kept.

10.7

10.1

10.0

  • HW-XF
  • VIPC

Synopsys Synplify

Of the different service packs (SP1,SP2,...) only the latest will be kept, as it contains all the changes from the previous SPs.

L-2016.09

J-2014.09

I-2014.03

I-2013.09

F-2011.09

  • PureDigital

E-2011.03

  • VIPC

C-2009.06

  • Labo

Xilinx Vivado

Recommended by Xilinx for 7 Series and newer. For older FPGAs use Xilinx ISE.

2018.1

Changes
Zynq UltraScale+™ RFSoC and Virtex UltraScale+ HBM devices
Increased productivity via ease of use improvements in IP flows and IP Integrator
New helper IPs and device support for Partial Reconfiguration
New capabilities and functions in Model Composer
Improved UltraScale+ Implementation: 5.5% higher Fmax, 1.6x faster compile times

2017.2

  • Astrocast

2014.4

  • Dormouse

Xilinx ISE

Recommended by Xilinx for 6 Series and older. For newer FPGAs use Xilinx Vivado.

14.7 - last major release

  • Labo18
  • Dormouse

14.5

13.4

  • BroadEnc

12.1

  • Labo / EDA libs
  • EzCat
  • PureDigital

9.2

  • VerifThin

Microsemi Libero

Of the different service packs (SP1,SP2,...) only the latest will be kept, as it contains all the changes from the previous SPs.

Recommended by Microsemi:

  • Libero SoC v11.0 for SmartFusion2, SmartFusion, Fusion, ProASIC3, IGLOO, IGLOO2 and Fusion families
  • Libero IDE v9.1 for older families

Dialog-warning.png

Libero SoC v11.3 and FlashPro v11.3 are the MINIMUM versions required for FlashPro5 on Windows. Libero IDE v8.6 SP1 and FlashPro 8.6 SP1 are the MINIMUM versions required for FlashPro4.
see FlashPro Software and Hardware Installtion Guide

Dialog-warning.png

The following Evaluation and Silver licenses support Libero SoC PolarFire, Libero SoC v11.8, and above versions only. Libero IDE v9.2 SP3, Libero SoC v11.7 SP3 and lower versions do not support Evaluation and Silver licenses. If you are using one of these Libero IDE or Libero SoC versions, you need to purchase Gold, Platinum or Standalone license.

11.8

  • Labo18

version 11.8 vs. 11.0

  • new Silver license
  • Windows 10 support
  • bugfixes and enhancements in placer, bank assigner, Repair Minimum Delay Violations, ...

11.0

  • Labo 13

10.0

  • HW-XF

9.1

  • Labo
  • PureDigital
Personal tools
Namespaces
Variants
Actions
Navigation
Browse
Toolbox